Tester l'algorithme :


(cliquer sur le bouton ci-dessus pour lancer ou relancer l'exécution de l'algorithme)
Remarque : si les messages "Algorithme lancé" et "Algorithme terminé" n'apparaissent pas au bout d'un moment dans la zone ci-dessous, c'est que l'algorithme contient une erreur.

Résultats :

Code de l'algorithme :
1     VARIABLES
2       a EST_DU_TYPE NOMBRE
3       b EST_DU_TYPE NOMBRE
4       N EST_DU_TYPE NOMBRE
5       i EST_DU_TYPE NOMBRE
6       compteur EST_DU_TYPE NOMBRE
7     DEBUT_ALGORITHME
8       AFFICHER "Nombres de choix de valeurs de a et de b : "
9       LIRE N
10      AFFICHER N
11      compteur PREND_LA_VALEUR 0
12      POUR i ALLANT_DE 1 A N
13        DEBUT_POUR
14        a PREND_LA_VALEUR random()
15        b PREND_LA_VALEUR random()
16        SI (abs(a-b)>=0.5) ALORS
17          DEBUT_SI
18          TRACER_POINT (a,b)
19          compteur PREND_LA_VALEUR compteur+1
20          FIN_SI
21        FIN_POUR
22      AFFICHER "Événement E réalisé avec la fréquence : "
23      compteur PREND_LA_VALEUR compteur/N
24      AFFICHER compteur
25    FIN_ALGORITHME